Author Topic: Engine Light after regulator change  (Read 439 times)

January 23, 2018, 12:31:31 PM
Read 439 times

c

  • Newbie

  • Offline
  • *

  • 2
    • View Profile
Hi All,

This is my first post here on the forum!  :)

I need some help regarding my 2005 Forester 2.5X.

A few weeks ago the battery charge light and handbrake light came on my instrument panel. We established that the alternator is not charging and testing the charge, the alternator was not charging and the battery was at 11.3 volts.
We took the alternator to a reputable auto electrical shop and they replaced the regulator on the alternator. (Part nr. REG5054) After we got the car back the battery charge light and handbrake light was off, but the engine light was now on. They tried to reset the engine light, but within a few seconds it was on again. The diagnostic fault number is P2503 "Powertrain Charging System Voltage Low".  They then replaced the regulator with a different make, but still the engine light still came on after the fault was cleared. The fault code is still the same one. The charge voltage is now 14.1 volts.

Does anyone what might cause the problem? Any help will be appreciated.

January 23, 2018, 02:56:05 PM
Reply #1

berndp

  • Hero Member

  • Offline
  • *****

  • 1175
    • View Profile
    • Email
Check ALL the fuses, inside and engine compartment.
Pull each one out.
If it fits loose, slightly twist the spades, so that it can make good contact again.
In engine compartment, pull all the relays out, one-by-one, and re-insert.
Subaru Forester 2005 2.5 Xsel
Always looking for a tar free "road"
Brackenfell, W'Cape

January 23, 2018, 03:10:14 PM
Reply #2

c

  • Newbie

  • Offline
  • *

  • 2
    • View Profile
Thanks, I will try that and come back to you :)