Author Topic: Throttle Response  (Read 549 times)

February 08, 2018, 10:46:55 AM
Read 549 times

dk

  • Newbie

  • Offline
  • *

  • 46
    • View Profile
    • Email
Good day all

Glad to report the XT is running well after a rebuild.

I have an odd throttle response issue.
It seems "hesitant" to pull off once the throttle pedal is pushed beyond 1/3rd of the way.
ie: push the throttle pedal slightly and she pulls off nice n slow
ie: push the throttle beyond about 1/3 of the way and its as though she wants to go, thinks about it, then goes.

I'm wondering if its just the throttle body that's a bit dirty or on its way out? Or a tuning issue?

Anyone have advice?
His: 2005 XT Auto Silver
-76mm turbo-back exhaust
-Autobahn88 turbo inlet
-K&N Drop-in Filter
-Some or other Big Chinese Intercooler & Greddy BOV
-Fury Racing tuned

Hers: 2005 XS Auto Gold

February 08, 2018, 11:00:57 AM
Reply #1

FozzieDriver

  • Hero Member

  • Offline
  • *****
  • Blue Wasabi

  • 927
    • View Profile
    • Email
Good news that you done.
You got a cable throttle right?
Could be a MAF thing.
Air cleaner new?
Have you actually logged anything to see if there is anything untoward?
Forester XT 2008 MT
TD04, STi IC, 76mm DP, GFB EBC, Coolboost WMI, WHP built and Intent Tuned. Blue Wasabi V3.5

February 20, 2018, 12:17:09 PM
Reply #2

dk

  • Newbie

  • Offline
  • *

  • 46
    • View Profile
    • Email
Its a Drive by wire setup on this foz, so no, not a direct cable to the TB.
Air filter was replaced recently enough to be clean. I should strip and clean the entire intake and get an oil catch can though.

Nope no logging, I should get my hands on all the equipment and software. Anybody have a lead or used set for this?

I've done some testing to try eliminate a few things.

1) In neutral/park, the response feels fine. RPM's jump up the moment the throttle is touched, not the same as when in Drive.
2) On a cold start, the engine wants to idle at 1500rpm, dab the throttle and the idle drops to 800 or so as normal.
3) Noticed during cold mornings, I'm getting a vibration from the drivetrain, slight judder whenever I'm standing still or crawling with the transmission in Drive and my foot on the brakes either lightly (crawling forward) or fully (standing still). The moment I go into neutral or park the judder disappears.


His: 2005 XT Auto Silver
-76mm turbo-back exhaust
-Autobahn88 turbo inlet
-K&N Drop-in Filter
-Some or other Big Chinese Intercooler & Greddy BOV
-Fury Racing tuned

Hers: 2005 XS Auto Gold

February 20, 2018, 02:12:13 PM
Reply #3

Veneficus

  • Global Moderator
  • Hero Member

  • Offline
  • *****
  • Windg@t XT driver

  • 2038
    • View Profile
    • Email
...
2) On a cold start, the engine wants to idle at 1500rpm, dab the throttle and the idle drops to 800 or so as normal.
...
Cold start has always sat at 1500 RPM on mine and drops down as engine heats up
2007 2.5XT Manual (and boy did I have to search for manual one)